[syncope-users] ContentLoader Error

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[syncope-users] ContentLoader Error

Luca Lori
Hi,

I've followed the procedure to start using Syncope and I've configured my local environment with Tomcat 7, Oracle db 10g and Maven 3.
I'm able to properly build the packages and deploy them into Tomcat but when I try to login with admin/password I receive the "Wrong user id and/or password" message.
I've checked the logs and I can see an error in loading the default content, more in detail:

13:44:02.418 ERROR org.syncope.core.init.ContentLoader - While loading default content
org.dbunit.dataset.NoSuchColumnException: SYNCOPEROLE.INHERITVIRTUALATTRIBUTES -  (Non-uppercase input column: inheritVirtualAttributes) in ColumnNameToIndexes cache map. Note that the map's column names are NOT case sensitive.

I've configured the content.xml as the sample provided in the installation guide (attached to this mail together with the Syncope logs).

Can you help me in solving this?

Thanks in advance,
Bye,
Luca

content.xml (7K) Download Attachment
syncope_logs.zip (22K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [syncope-users] ContentLoader Error

Fabio Martelli

Il giorno 08/giu/2011, alle ore 15.24, Luca Lori ha scritto:

> Hi,
>
> I've followed the procedure to start using Syncope and I've configured my local environment with Tomcat 7, Oracle db 10g and Maven 3.
> I'm able to properly build the packages and deploy them into Tomcat but when I try to login with admin/password I receive the "Wrong user id and/or password" message.
> I've checked the logs and I can see an error in loading the default content, more in detail:
>
> 13:44:02.418 ERROR org.syncope.core.init.ContentLoader - While loading default content
> org.dbunit.dataset.NoSuchColumnException: SYNCOPEROLE.INHERITVIRTUALATTRIBUTES -  (Non-uppercase input column: inheritVirtualAttributes) in ColumnNameToIndexes cache map. Note that the map's column names are NOT case sensitive.
>
> I've configured the content.xml as the sample provided in the installation guide (attached to this mail together with the Syncope logs).
>
> Can you help me in solving this?

Hi Luca,
I can help you but I need to see something more.
Please, perform a "mvn clean" from syncope root, zip the project and send it in mailing-list.

I'm waiting for your data.

Regards,
F.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[syncope-users] Re: ContentLoader Error

Luca Lori
In reply to this post by Luca Lori
Hi Fabio,

attached is the zip with my syncope project.

Appreciate your help!

Thanks a lot,
Bye,
Luca


On Jun 8, 3:45 pm, Fabio Martelli <[hidden email]> wrote:
> Il giorno 08/giu/2011, alle ore 15.24, Luca Lori ha scritto:
>
> > Hi,
>
> > I've followed the procedure to start using Syncope and I've configured my local environment with Tomcat 7, Oracle db 10g and Maven 3.
> > I'm able to properly build the packages and deploy them into Tomcat but when I try to login with admin/password I receive the "Wrong user id and/or password" message.
> > I've checked the logs and I can see an error in loading the default content, more in detail:
>
> > 13:44:02.418 ERROR org.syncope.core.init.ContentLoader - While loading default content
> > org.dbunit.dataset.NoSuchColumnException: SYNCOPEROLE.INHERITVIRTUALATTRIBUTES -  (Non-uppercase input column: inheritVirtualAttributes) in ColumnNameToIndexes cache map. Note that the map's column names are NOT case sensitive.
>
> > I've configured the content.xml as the sample provided in the installation guide (attached to this mail together with the Syncope logs).
>
> > Can you help me in solving this?
>
> Hi Luca,
> I can help you but I need to see something more.
> Please, perform a "mvn clean" from syncope root, zip the project and send it in mailing-list.
>
> I'm waiting for your data.
>
> Regards,
> F.

syncope_project.zip (24K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [syncope-users] Re: ContentLoader Error

Fabio Martelli

Il giorno 08/giu/2011, alle ore 19.35, Luca Lori ha scritto:

Hi Fabio,

attached is the zip with my syncope project.

Appreciate your help!
Hi Luca,
the problem is inside your content.xml file.
You have to replace the following row

<SyncopeRole id="0" name="/" inheritAttributes="0" inheritDerivedAttributes="0" inheritVirtualAttributes="0"/>

with this

<SyncopeRole id="0" name="/" inheritAttributes="0" inheritDerivedAttributes="0"/>

As you can see, you have just to remove the attribute inheritVirtualAttributes.
This attribute is related to a new feature implemented into the trunk. 

I know that you take the content.xml referenced inside the wiki page but that link was wrong; I have just replaced it with the right one (https://syncope.googlecode.com/svn/branches/0_5_X/core/src/main/resources/content.xml).

Thanks for your contribution and have a nice work with Syncope.

Regards,
F.


Thanks a lot,
Bye,
Luca


On Jun 8, 3:45 pm, Fabio Martelli <[hidden email]> wrote:
> Il giorno 08/giu/2011, alle ore 15.24, Luca Lori ha scritto:
>
> > Hi,
>
> > I've followed the procedure to start using Syncope and I've configured my local environment with Tomcat 7, Oracle db 10g and Maven 3.
> > I'm able to properly build the packages and deploy them into Tomcat but when I try to login with admin/password I receive the "Wrong user id and/or password" message.
> > I've checked the logs and I can see an error in loading the default content, more in detail:
>
> > 13:44:02.418 ERROR org.syncope.core.init.ContentLoader - While loading default content
> > org.dbunit.dataset.NoSuchColumnException: SYNCOPEROLE.INHERITVIRTUALATTRIBUTES -  (Non-uppercase input column: inheritVirtualAttributes) in ColumnNameToIndexes cache map. Note that the map's column names are NOT case sensitive.
>
> > I've configured the content.xml as the sample provided in the installation guide (attached to this mail together with the Syncope logs).
>
> > Can you help me in solving this?
>
> Hi Luca,
> I can help you but I need to see something more.
> Please, perform a "mvn clean" from syncope root, zip the project and send it in mailing-list.
>
> I'm waiting for your data.
>
> Regards,
> F.
<syncope_project.zip>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[syncope-users] Re: ContentLoader Error

Luca Lori
Now it works, thanks!

Best Regards,
Luca

On Jun 9, 2:43 pm, Fabio Martelli <[hidden email]> wrote:

> Il giorno 08/giu/2011, alle ore 19.35, Luca Lori ha scritto:
>
> > Hi Fabio,
>
> > attached is the zip with my syncope project.
>
> > Appreciate your help!
>
> Hi Luca,
> the problem is inside your content.xml file.
> You have to replace the following row
>
> <SyncopeRole id="0" name="/" inheritAttributes="0" inheritDerivedAttributes="0" inheritVirtualAttributes="0"/>
>
> with this
>
> <SyncopeRole id="0" name="/" inheritAttributes="0" inheritDerivedAttributes="0"/>
>
> As you can see, you have just to remove the attribute inheritVirtualAttributes.
> This attribute is related to a new feature implemented into the trunk.
>
> I know that you take the content.xml referenced inside the wiki page but that link was wrong; I have just replaced it with the right one (https://syncope.googlecode.com/svn/branches/0_5_X/core/src/main/resou...).
>
> Thanks for your contribution and have a nice work with Syncope.
>
> Regards,
> F.
>
>
>
> > Thanks a lot,
> > Bye,
> > Luca
>
> > On Jun 8, 3:45 pm, Fabio Martelli <[hidden email]> wrote:
> > > Il giorno 08/giu/2011, alle ore 15.24, Luca Lori ha scritto:
>
> > > > Hi,
>
> > > > I've followed the procedure to start using Syncope and I've configured my local environment with Tomcat 7, Oracle db 10g and Maven 3.
> > > > I'm able to properly build the packages and deploy them into Tomcat but when I try to login with admin/password I receive the "Wrong user id and/or password" message.
> > > > I've checked the logs and I can see an error in loading the default content, more in detail:
>
> > > > 13:44:02.418 ERROR org.syncope.core.init.ContentLoader - While loading default content
> > > > org.dbunit.dataset.NoSuchColumnException: SYNCOPEROLE.INHERITVIRTUALATTRIBUTES -  (Non-uppercase input column: inheritVirtualAttributes) in ColumnNameToIndexes cache map. Note that the map's column names are NOT case sensitive.
>
> > > > I've configured the content.xml as the sample provided in the installation guide (attached to this mail together with the Syncope logs).
>
> > > > Can you help me in solving this?
>
> > > Hi Luca,
> > > I can help you but I need to see something more.
> > > Please, perform a "mvn clean" from syncope root, zip the project and send it in mailing-list.
>
> > > I'm waiting for your data.
>
> > > Regards,
> > > F.
> > <syncope_project.zip>
Loading...